Aiuto - Cerca - Utenti - Calendario
Versione completa: Card Server+smargo Triple+fritzbox 7390
Skizzo3000's Net > Fritz!Box > Modifiche Software
gasgas
Ciao a tutti ragazzi, premetto che ho fatto un pochino di esperienza con il mio ipbox, vu ultimo e gigablue in merito a condivisione delle Card, principalmente con oscam. Ho da tempo un 7270 v2 e un 7390 e ora ho acquistato un lettore usb smargo triple e volevo connetterlo al mio 7390 , ma non ho la pi pallida idea da dove cominciare.
Ho capito che devo modificare il firmware originale con freetz, ma non riesco a trovarlo e non saprei bene cosa farci....
Sapreste darmi una mano o dove trovare una guida??
skizzo3000
Freetz lo trovi qui
http://freetz.org/

una volta che sei nel menuconfig ti conviene selezionare nei pakketti
nano
tcpdump

poi nelle avanzate kernel modules devi aggiungere i diver
usb_serial
ftdixx
cpxxx
plxxx

dopo aver creato questo firmware sei alla base per poter caricare oscam compilato per freetz

Per compilare oscam x freetz, ho uno script gia pronto...

Sai che la condivisione di carte ILLEGALE ma se tu intendi leggere la tua TVSat per poi usarla nei tuoi decoders di casa non ci sono problemi.

Sk3
gasgas
Mitico e velocissimo come sempre skizzo...
Ovviamente devo condividere la mia Tivusat che domande... biggrin.gif
Allora, ho trovato il sito, scaricato freetz 1.2, installato, credo, in ubuntu 12.10 con i relativi pacchetti.
Ma quando lancio make menuconfig mi risponde che devo prima lanciare mask 0022 (Makefile:110: *** Please run "umask 0022", it is now 0002. Arresto.)
Lo faccio e poi parte freetz. Ma alcune volte si crasha non so perquale motivo. (make: *** [menuconfig] Errore di segmentazione (creato dump del core))
Ora che mi hai detto cosa selezionare ci riprovo...
Tra l'altro, mi hanno detto che lo smargo e' compatibile solo con il kernel 2.6.30.
Ora, come faccio a sapere che kernel ho sul mio? Tu sai se e' vero?
Compilare, parola troppo usata dai linuxman e sconusciuta ai finestrai come me...
Ho trovato sul sito ufficiale di oscam delle versioni specifiche per fb 7390, centrano qualcosa?
Io immaginavo che dovevo prendere questo file e i file di conf e metterli con filezilla in qualche cartella del fb...
o no?

CITAZIONE(skizzo3000 @ Wed 3 Oct 2012, 06:49 PM) *
Freetz lo trovi qui
http://freetz.org/

una volta che sei nel menuconfig ti conviene selezionare nei pakketti
nano
tcpdump

poi nelle avanzate kernel modules devi aggiungere i diver
usb_serial
ftdixx
cpxxx
plxxx

dopo aver creato questo firmware sei alla base per poter caricare oscam compilato per freetz

Per compilare oscam x freetz, ho uno script gia pronto...

Sai che la condivisione di carte ILLEGALE ma se tu intendi leggere la tua TVSat per poi usarla nei tuoi decoders di casa non ci sono problemi.

Sk3
skizzo3000
ver linux-2.6.32

scarica il freetz trunk e non freetz 1.2...
io personalmente uso 12.04 LTS xk quello con il supporto 5anni... e poi il 32bit xk cos non ho rogne nella compilazione x i dispositivi embedded tipo fritz. Solo compilare android richiede il 64bit.

Io non conosco smargo o simili ma presumo siano visti come periferiche seriali. Se vuoi sapere di pi connetti lo smargo all'uso del tuo pc linux e poi da console digita lsusb e posta il risultato.

Posta il link relativo al oscam x freetz che vediamo.

Poi per mettere il file nel fritz... basta metterli su una usb smile.gif

Sk3
gasgas
2.6.32 e' la vers. kernel del fb 7390, esatto?
ora provo con il trunk...
ecco cosa mi da lsusb:
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 003: ID 058f:6364 Alcor Micro Corp. Hi-Speed 7-in-1 Flash Card Reader/Writer [Sabrent]
Bus 001 Device 004: ID 0424:2514 Standard Microsystems Corp. USB 2.0 Hub
Bus 002 Device 003: ID 0b05:179c ASUSTek Computer, Inc.
Bus 001 Device 005: ID 046d:c51a Logitech, Inc. MX Revolution/G7 Cordless Mouse
Bus 001 Device 006: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 001 Device 007: ID 046d:0990 Logitech, Inc. QuickCam Pro 9000
Bus 001 Device 008: ID 0403:6011 Future Technology Devices International, Ltd FT4232H Quad HS USB-UART/FIFO IC

quest'ultimo e' lo smargo triple.
Si anche la mia e' la 12.04 lts 32
questo il link di oscam http://www.streamboard.tv/wbb2/thread.php?...7723&page=8

CITAZIONE(skizzo3000 @ Wed 3 Oct 2012, 09:07 PM) *
ver linux-2.6.32

scarica il freetz trunk e non freetz 1.2...
io personalmente uso 12.04 LTS xk quello con il supporto 5anni... e poi il 32bit xk cos non ho rogne nella compilazione x i dispositivi embedded tipo fritz. Solo compilare android richiede il 64bit.

Io non conosco smargo o simili ma presumo siano visti come periferiche seriali. Se vuoi sapere di pi connetti lo smargo all'uso del tuo pc linux e poi da console digita lsusb e posta il risultato.

Posta il link relativo al oscam x freetz che vediamo.

Poi per mettere il file nel fritz... basta metterli su una usb smile.gif

Sk3

gasgas
ancora questo...
dino@dino-linux-minipc:~/freetz-trunk$ make menuconfig
Makefile:100: *** Please run "umask 0022 make/mod/files/root" to fix file permissions. Arresto.
dino@dino-linux-minipc:~/freetz-trunk$ umask 0022 make/mod/files/root
dino@dino-linux-minipc:~/freetz-trunk$ make menuconfig
Makefile:100: *** Please run "umask 0022 make/mod/files/root" to fix file permissions. Arresto.
dino@dino-linux-minipc:~/freetz-trunk$

cosa sbaglio? almeno prima con umask poi partiva, ora neanche...

CITAZIONE(gasgas @ Thu 4 Oct 2012, 08:26 AM) *
2.6.32 e' la vers. kernel del fb 7390, esatto?
ora provo con il trunk...

gasgas
Io mi rispondo da solo alle volte... :-)
Sono riuscito a creare l'immagine con freetz, con le modifiche che mi hai detto, caricato, mia sorpresa, e' rimasto in italiano la parte standard, ottimo.
Ora, ho collegato lo smargo alla seconda usb del 7390, da panoramica mi rileva la pen usb e un altro apparecchio non conosciuto.
Per non saper ne leggere ne scrivere, ho dato da telnet lsusb e questo e' uscito
root@fritz:/var/mod/root# lsusb
BUS=002
DEV=001
VID=1d6b
PID=0001
CLS=09
SCL=00
SPEED='full'
VER='1.1'
ISOC=0
INUM=1
ICLS1=09
ISCL1=00

BUS=001
DEV=001
VID=1d6b
PID=0002
CLS=09
SCL=00
SPEED='hi'
VER='2.0'
ISOC=0
INUM=1
ICLS1=09
ISCL1=00

BUS=001
DEV=002
VID=0403
PID=6011
CLS=00
SCL=00
SPEED='hi'
VER='2.0'
ISOC=0
INUM=3
ICLS1=255
ISCL1=255
ICLS2=255
ISCL2=255
ICLS3=255
ISCL3=255

BUS=001
DEV=003
VID=cd12
PID=ef18
CLS=00
SCL=00
SPEED='hi'
VER='2.0'
ISOC=0
INUM=1
ICLS1=08
ISCL1=06

root@fritz:/var/mod/root#

Quindi? non e' supportato?
Come li metto i file di oscam e come configuro il tutto?
skizzo3000
secondo me corretto quanto postato.

Ora metti nella usb pen l'eseguibile di oscam e i file di conf, poi colleghi la pen e via telnet vai nella pen /var/media/ecc ecc oppure la trovi con
mount

verifica che oscam sia +x altrimenti
chmod +x oscam

poi avvia oscam
./oscam -c /var/media/ecce ccececec/oscam.conf

Sk3
gasgas
Tutto fatto...ma risultato lontano...
ecco cosa risponde oscam

2012/10/05 13:41:03 0 s services reloaded: 0 services freed, 20 services loaded, rejected 0
2012/10/05 13:41:03 0 s userdb reloaded: 4 accounts loaded, 0 expired, 0 disabled
2012/10/05 13:41:03 0 s signal handling initialized (type=sysv)
2012/10/05 13:41:03 0 s 446 service-id's loaded in 11ms
2012/10/05 13:41:03 0 s 37 tier-id's loaded
2012/10/05 13:41:03 0 s 1000 provid's loaded
2012/10/05 13:41:03 0 s ERROR: Cannot open file "/var/media/ftp/uStor01/oscam.guess" (errno=2 No such file or directory)
2012/10/05 13:41:03 0 s ERROR: Cannot open file "/var/media/ftp/uStor01/oscam.ird" (errno=2 No such file or directory)
2012/10/05 13:41:03 0 s ERROR: Cannot open file "/var/media/ftp/uStor01/oscam.whitelist" (errno=2 No such file or directory)
2012/10/05 13:41:03 0 s ERROR: Cannot open file "/var/media/ftp/uStor01/oscam.cacheex" (errno=2 No such file or directory)
2012/10/05 13:41:03 0 s Starting listener 0
2012/10/05 13:41:03 0 s monitor: disabled
2012/10/05 13:41:03 0 s Starting listener 0
2012/10/05 13:41:03 0 s camd33: disabled
2012/10/05 13:41:03 0 s Starting listener 0
2012/10/05 13:41:03 0 s camd35: disabled
2012/10/05 13:41:03 0 s Starting listener 0
2012/10/05 13:41:03 0 s cs378x: disabled
2012/10/05 13:41:03 0 s Starting listener 0
2012/10/05 13:41:03 0 s Starting listener 1
2012/10/05 13:41:03 0 s newcamd: initialized (fd=7, port=11501, crypted)
2012/10/05 13:41:03 0 s -> CAID: 183D PROVID: 005411, 000000
2012/10/05 13:41:03 0 s pandora: disabled
2012/10/05 13:41:03 0 s Starting listener 0
2012/10/05 13:41:03 0 s csp: disabled
2012/10/05 13:41:03 0 s Starting listener 0
2012/10/05 13:41:03 0 s radegast: disabled
2012/10/05 13:41:03 0 s starting thread http
2012/10/05 13:41:03 5EBBA8 h HTTP Server listening on port 8189
2012/10/05 13:41:03 0 s http thread started
2012/10/05 13:41:03 0 s starting thread reader check
2012/10/05 13:41:03 0 s reader check thread started
2012/10/05 13:41:03 0 s starting thread check
2012/10/05 13:41:03 0 s check thread started
2012/10/05 13:41:03 0 s sky [mouse] creating thread for device /dev/ttyUSB0
2012/10/05 13:41:03 608CF0 r sky [mouse] ERROR: Opening device /dev/ttyUSB0 (errno=2 No such file or directory)
2012/10/05 13:41:03 608CF0 r sky [mouse] Cannot open device: /dev/ttyUSB0
2012/10/05 13:41:03 0 s sct [mouse] creating thread for device /dev/ttyUSB1
2012/10/05 13:41:03 60A4F0 r sct [mouse] ERROR: Opening device /dev/ttyUSB1 (errno=2 No such file or directory)
2012/10/05 13:41:03 60A4F0 r sct [mouse] Cannot open device: /dev/ttyUSB1
2012/10/05 13:41:03 0 s tvsat [mouse] creating thread for device /dev/ttyUSB2
2012/10/05 13:41:03 60BCF0 r tvsat [mouse] ERROR: Opening device /dev/ttyUSB2 (errno=2 No such file or directory)
2012/10/05 13:41:03 60BCF0 r tvsat [mouse] Cannot open device: /dev/ttyUSB2
2012/10/05 13:41:03 0 s loadbalancer: can't read from file /tmp/.oscam/stat
2012/10/05 13:41:03 0 s waiting for local card init

Immagino che sia il lettore che non viene riconosciuto.
ecco il file server
[reader]
label = Tvsat
protocol = mouse
detect = CD
device = /dev/ttyUSB2
group = 1
mhz = 357
cardmhz = 368
caid = 183D
ident = 183D:005411,000000
rsakey = A92DA72FEEACF2947B003ED652153B189E4043B0138C368BDF6B9ED77DDAD6C0761A2198AEB3FC97
A19C9D01CA769B3FFFE4F6E70FA4E0696A8980E18D8C58E11D817121346E3E66457FDD84CFA72589B
25B538EFC304361B54845F39E9EFA52D805E5FD86B595B366C35716ABC91FA3DC159C9F4D8164B5
EMMCache = 1,3,2

CITAZIONE(skizzo3000 @ Thu 4 Oct 2012, 06:30 PM) *
secondo me corretto quanto postato.

Ora metti nella usb pen l'eseguibile di oscam e i file di conf, poi colleghi la pen e via telnet vai nella pen /var/media/ecc ecc oppure la trovi con
mount

verifica che oscam sia +x altrimenti
chmod +x oscam

poi avvia oscam
./oscam -c /var/media/ecce ccececec/oscam.conf

Sk3

skizzo3000
ok molto bene basta caricare il modulo usb-serial con i parametri pid e vid dello smargo
BUS=001
DEV=002
VID=0403
PID=6011
CLS=00
SCL=00
SPEED='hi'
VER='2.0'
ISOC=0
INUM=3
ICLS1=255
ISCL1=255
ICLS2=255
ISCL2=255
ICLS3=255
ISCL3=255

Cerca su google smargo usb serial.

poi una volta che hai caricato il modulo avrai accesso alle ttyUSB

cmq gia ora prova con lsmod e vedi cosa ha caricato.

Sk3
gasgas
Skizzo, ogni volta che leggo una tua rispsota mi fai fare un balzo di gioa... tongue.gif
Ho trovato questo in rete:
Taken from http://www.argolis.nl/downloads.html
Assigning the Argolis Triple Reader to new device names.

Place this file iin /etc/udev/rules.d/
By reconnecting the triple reader it will be assigned to the new device names.

Read the serial number of the triplereader: lsusb -d 403:6011 -v | grep iSerial
Serial number: 00000001
Readername: triplereader_TEST

The new names for the triplereader with serial number 00000001 will be:
P1 = /dev/triplereader_TEST00
P2 = /dev/triplereader_TEST01
P3 = /dev/triplereader_TEST02
Serial number: 0000ABCD
Readername: my_READER

The new names for the triplereader with serial number 0000ABCD will be:
P1 = /dev/my_READER00

ma la dir rlues.d e' di sola lettuara e non mi ci fa mettere il file.
e se lancio lsusb -d 403:6011 -v | grep iSerial
mi ritorna
ERROR: Device number expected for -d
Come procedo?

CITAZIONE(skizzo3000 @ Fri 5 Oct 2012, 08:10 PM) *
ok molto bene basta caricare il modulo usb-serial con i parametri pid e vid dello smargo
BUS=001
DEV=002
VID=0403
PID=6011
CLS=00
SCL=00
SPEED='hi'
VER='2.0'
ISOC=0
INUM=3
ICLS1=255
ISCL1=255
ICLS2=255
ISCL2=255
ICLS3=255
ISCL3=255

Cerca su google smargo usb serial.

poi una volta che hai caricato il modulo avrai accesso alle ttyUSB

cmq gia ora prova con lsmod e vedi cosa ha caricato.

Sk3

skizzo3000
no sei sulla strada sbagliata... quello che hai indicato nn server a nulla.

tu devi caricare usb-serial con pid e vid in modo che lui ti faccia i dev ttyUSB 0 1 2

na roba del genere

modprobe usbserial vendor=0x12d1 product=0x1001

Sk3
gasgas
Ok, io ho fatto
modprobe usbserial vendor=0x0403 product=0x6011

come verifico cosa ha fatto?

lsmod mi da cosi root@fritz:/var/mod/root# lsmod
Module Size Used by Tainted: P
usbserial 30352 0
ath_pktlog 19760 0
umac 611264 1 ath_pktlog
ath_dev 198176 2 ath_pktlog,umac
ath_dfs 53600 1 ath_dev
ath_spectral 59568 1 ath_dev
ath_rate_atheros 52144 2 ath_pktlog,ath_dev
ath_hal 480208 5 ath_pktlog,umac,ath_dev,ath_dfs,ath_spectral
asf 11632 5 umac,ath_dev,ath_dfs,ath_spectral,ath_hal
adf 16992 3 umac,ath_dev,ath_hal
aae 103696 3 umac,ath_dev,ath_hal
nls_iso8859_1 3424 1
nls_cp437 4960 1
vfat 12800 1
fat 59696 1 vfat
usb_storage 40064 1
sd_mod 29280 2
scsi_mod 112880 2 usb_storage,sd_mod
sch_sfq 7872 0
sch_llq 11008 0
sch_tbf 6272 0
kdsldmod 1223280 4
ohci_hcd 21648 0
ehci_hcd 38928 0
usbcore 150656 5 usbserial,usb_storage,ohci_hcd,ehci_hcd
ramzswap 20128 1
lzo_compress 2304 1 ramzswap
lzo_decompress 2592 1 ramzswap
dect_io 13472 0
avm_dect 282336 1 dect_io
capi_codec 477664 0
isdn_fbox_fon5 904160 5
pcmlink 314496 3 avm_dect,capi_codec,isdn_fbox_fon5
Piglet_noemif 35120 0
bmedrv 5712 0
opensrc_lkm 2080 1 bmedrv
aclap_driver_lkm 23696 0
sysKCode_lkm 16608 0
ethdriver_lkm 46560 1 aclap_driver_lkm
periap_driver_lkm 15904 1 ethdriver_lkm
timers_lkm 6416 0
bmdriver_lkm 14944 0
ap2ap_lkm 25984 6 umac,kdsldmod,aclap_driver_lkm,sysKCode_lkm,ethd
river_lkm,bmdriver_lkm
fusivlib_lkm 57376 9 umac,kdsldmod,bmedrv,aclap_driver_lkm,sysKCode_l
km,ethdriver_lkm,periap_driver_lkm,bmdriver_lkm,ap2ap_lkm
rtc_avm 6288 1 pcmlink
rtc_core 16720 1 rtc_avm
led_modul_Fritz_Box_7390 99472 2

CITAZIONE(skizzo3000 @ Thu 11 Oct 2012, 08:01 PM) *
no sei sulla strada sbagliata... quello che hai indicato nn server a nulla.

tu devi caricare usb-serial con pid e vid in modo che lui ti faccia i dev ttyUSB 0 1 2

na roba del genere

modprobe usbserial vendor=0x12d1 product=0x1001

Sk3
skizzo3000
se vei il modulo l'ha caricato ora devi vedere se ci sono i /dev/ttyUSB 0 1 2

ed in caso provare oscam

Sk3
gasgas
smile.gif

root@fritz:/dev# ls
1-1 kdsldptrace1 mtdblock13 ttyS0
1-1.4 kdsldptrace17 mtdblock14 ttyS1
1-1.4.1 kdsldptrace18 mtdblock15 ttyp0
1-1.4.3 kdsldptrace19 mtdblock2 ttyp1
1-1.4.4 kdsldptrace2 mtdblock3 ttyp2
adsl_mon kdsldptrace20 mtdblock4 ttyp3
avm_event kdsldptrace3 mtdblock5 ttyp4
avm_net_trace0 kdsldptrace4 mtdblock6 ttyp5
avm_net_trace128 kmem mtdblock7 ttyp6
avm_net_trace129 kmsg mtdblock8 ttyp7
avm_net_trace130 led mtdblock9 ttyp8
avm_net_trace131 loop0 net ttyp9
avm_net_trace132 loop1 network_latency ttypa
avm_net_trace133 loop2 network_throughput ttypb
avm_net_trace134 loop3 new_led ttypc
avm_net_trace135 loop4 null ttypd
avm_net_trace136 loop5 port ttype
avm_net_trace137 loop6 ppp ttypf
avm_net_trace138 loop7 ptmx tun
avm_net_trace139 mem pts urandom
avm_net_trace140 mtd0 ptyp0 usb1
avm_net_trace141 mtd0ro ptyp1 usb2
avm_net_trace142 mtd1 ptyp2 usbdev1.1_ep00
avm_net_trace143 mtd10 ptyp3 usbdev1.1_ep81
avm_net_trace160 mtd11 ptyp4 usbdev1.21_ep00
avm_net_trace161 mtd12 ptyp5 usbdev1.21_ep02
avm_net_trace162 mtd13 ptyp6 usbdev1.21_ep04
avm_net_trace163 mtd14 ptyp7 usbdev1.21_ep06
avm_pa mtd15 ptyp8 usbdev1.21_ep81
avm_power mtd1ro ptyp9 usbdev1.21_ep83
block mtd2 ptypa usbdev1.21_ep85
bme mtd2ro ptypb usbdev1.25_ep00
caldata mtd3 ptypc usbdev1.25_ep02
capi20 mtd3ro ptypd usbdev1.25_ep81
capi_oslib mtd4 ptype usbdev1.2_ep00
char mtd4ro ptypf usbdev1.2_ep81
console mtd5 ramzswap0 usbdev1.3_ep00
cpu_dma_latency mtd5ro random usbdev1.3_ep81
debug mtd6 rtc usbdev1.86_ep00
dect_io mtd6ro rtc0 usbdev1.86_ep02
full mtd7 sda usbdev1.86_ep82
fuse mtd8 sda1 usbdev2.1_ep00
kdsld mtd9 sdb usbdev2.1_ep81
kdsld_misc mtdblock0 sdb1 watchdog
kdsld_multid mtdblock1 tffs wlan_eeprom1
kdsld_traffic mtdblock10 tiatm wlan_eeprom2
kdsld_user mtdblock11 tty zero
kdsldptrace0 mtdblock12 tty0
root@fritz:/dev# modprobe usbserial vendor=0x0403 product=0x6011
root@fritz:/dev# ls
1-1 kdsldptrace17 mtdblock15 ttyUSB1
1-1.4 kdsldptrace18 mtdblock2 ttyUSB2
1-1.4.1 kdsldptrace19 mtdblock3 ttyp0
1-1.4.3 kdsldptrace2 mtdblock4 ttyp1
1-1.4.4 kdsldptrace20 mtdblock5 ttyp2
adsl_mon kdsldptrace3 mtdblock6 ttyp3
avm_event kdsldptrace4 mtdblock7 ttyp4
avm_net_trace0 kmem mtdblock8 ttyp5
avm_net_trace128 kmsg mtdblock9 ttyp6
avm_net_trace129 led net ttyp7
avm_net_trace130 loop0 network_latency ttyp8
avm_net_trace131 loop1 network_throughput ttyp9
avm_net_trace132 loop2 new_led ttypa
avm_net_trace133 loop3 null ttypb
avm_net_trace134 loop4 port ttypc
avm_net_trace135 loop5 ppp ttypd
avm_net_trace136 loop6 ptmx ttype
avm_net_trace137 loop7 pts ttypf
avm_net_trace138 mem ptyp0 tun
avm_net_trace139 mtd0 ptyp1 urandom
avm_net_trace140 mtd0ro ptyp2 usb1
avm_net_trace141 mtd1 ptyp3 usb2
avm_net_trace142 mtd10 ptyp4 usbdev1.1_ep00
avm_net_trace143 mtd11 ptyp5 usbdev1.1_ep81
avm_net_trace160 mtd12 ptyp6 usbdev1.21_ep00
avm_net_trace161 mtd13 ptyp7 usbdev1.21_ep02
avm_net_trace162 mtd14 ptyp8 usbdev1.21_ep04
avm_net_trace163 mtd15 ptyp9 usbdev1.21_ep06
avm_pa mtd1ro ptypa usbdev1.21_ep81
avm_power mtd2 ptypb usbdev1.21_ep83
block mtd2ro ptypc usbdev1.21_ep85
bme mtd3 ptypd usbdev1.25_ep00
caldata mtd3ro ptype usbdev1.25_ep02
capi20 mtd4 ptypf usbdev1.25_ep81
capi_oslib mtd4ro ramzswap0 usbdev1.2_ep00
char mtd5 random usbdev1.2_ep81
console mtd5ro rtc usbdev1.3_ep00
cpu_dma_latency mtd6 rtc0 usbdev1.3_ep81
debug mtd6ro sda usbdev1.86_ep00
dect_io mtd7 sda1 usbdev1.86_ep02
full mtd8 sdb usbdev1.86_ep82
fuse mtd9 sdb1 usbdev2.1_ep00
kdsld mtdblock0 tffs usbdev2.1_ep81
kdsld_misc mtdblock1 tiatm watchdog
kdsld_multid mtdblock10 tty wlan_eeprom1
kdsld_traffic mtdblock11 tty0 wlan_eeprom2
kdsld_user mtdblock12 ttyS0 zero
kdsldptrace0 mtdblock13 ttyS1
kdsldptrace1 mtdblock14 ttyUSB0
root@fritz:/dev#

oooooookkkk...... mitico skizzo....

pero' ancora niente, questo risponde oscam:
2012/10/14 20:54:33 0 s starting thread check
2012/10/14 20:54:33 0 s check thread started
2012/10/14 20:54:33 0 s sky [mouse] creating thread for device 001:021
2012/10/14 20:54:33 608CF0 r sky [mouse] ERROR: Opening device 001:021 (errno=2 No such file or directory)
2012/10/14 20:54:33 608CF0 r sky [mouse] Cannot open device: 001:021
2012/10/14 20:54:33 0 s sct [mouse] creating thread for device 001:021
2012/10/14 20:54:33 60A4F0 r sct [mouse] ERROR: Opening device 001:021 (errno=2 No such file or directory)
2012/10/14 20:54:33 60A4F0 r sct [mouse] Cannot open device: 001:021
2012/10/14 20:54:33 0 s tvsat [mouse] creating thread for device 001:021
2012/10/14 20:54:33 60BCF0 r tvsat [mouse] ERROR: Opening device 001:021 (errno=2 No such file or directory)
2012/10/14 20:54:33 60BCF0 r tvsat [mouse] Cannot open device: 001:021
2012/10/14 20:54:33 0 s loadbalancer: can't read from file /tmp/.oscam/stat
2012/10/14 20:54:33 0 s waiting for local card init

001:021 li ho presi da lsusb, immagino...
(BUS=001
DEV=021
VID=0403
PID=6011...)

credo che il problema sia nella configurazione del file oscam.server
[reader]
label = Tvsat
protocol = mouse
detect = CD
device = /dev/ttyUSB2
device = 001:021
group = 1
cardmhz = 368
mhz = 368
caid = 183D
ident = 183D:005411,000000
....

Ho cercato la guida, ma non mi ha aiutato. Non capisco perche' 2 device, protocol ho provato anche smartreader...

CITAZIONE(skizzo3000 @ Thu 11 Oct 2012, 09:20 PM) *
se vei il modulo l'ha caricato ora devi vedere se ci sono i /dev/ttyUSB 0 1 2

ed in caso provare oscam

Sk3

skizzo3000
devi controllare dmesg che ti dice...
prova ad usare il modulo usb-ftdi.ko al posto di usb-serial
e controlla poi dmesg cosa dice.

Sk3
gasgas
Allora, ho fatto modprobe ftdi_sio vendor=0x0403 product=0x6011 esatto?
in dev compaiono i ttyUSB0 1 2
la risposta di dmesg te lo allegata come txt, ma oscam risponde sempre uguale

CITAZIONE(skizzo3000 @ Fri 19 Oct 2012, 12:36 AM) *
devi controllare dmesg che ti dice...
prova ad usare il modulo usb-ftdi.ko al posto di usb-serial
e controlla poi dmesg cosa dice.

Sk3

skizzo3000
ok ora che hai USB 0 1 2 correttamente installate devi correggere la conf di oscam
UNA SOLA riga device !
device = /dev/ttyUSBx

Sk3
gasgas
OOH OOH OOH!!!!!
E' arrivato Babbo Natale in anticipo quest'anno!!! :-)
No dai non mi esalto ancora, perche' ho solo provato da remoto, ma non avevo dentro le card nel lettore,
pero' il log di oscam non dice piu' error nel device, anzi... stasera provo dal vivo con le card.
Ma poi dove inserico i comandi per far partire tutto in automatico?

CITAZIONE(skizzo3000 @ Sun 21 Oct 2012, 09:52 AM) *
ok ora che hai USB 0 1 2 correttamente installate devi correggere la conf di oscam
UNA SOLA riga device !
device = /dev/ttyUSBx

Sk3

gasgas
Ok, per adesso babbo e' fermo al casello...
allora, la card irdeto sembra andare, le altre 2 tvasat nagra e un' "altra" ritornano un errore e non si inizializano a dovere.
ti ellego il log

CITAZIONE(gasgas @ Sun 21 Oct 2012, 10:49 AM) *
OOH OOH OOH!!!!!
E' arrivato Babbo Natale in anticipo quest'anno!!! :-)
No dai non mi esalto ancora, perche' ho solo provato da remoto, ma non avevo dentro le card nel lettore,
pero' il log di oscam non dice piu' error nel device, anzi... stasera provo dal vivo con le card.
Ma poi dove inserico i comandi per far partire tutto in automatico?

skizzo3000
io mi fermo qui xk il problema relativo ai moduli e fritz mi pare RISOLTO wink.gif
Per il resto ti invito a scrivere nei forum specialistici.

Sk3
gasgas
Ho aprofittato tantissimo di te... e sono arrivato dove non avrei potuto mai!!
E' tutto il pomeriggio che provo con innumerevoli configurazioni ma niente...ma prima o poi ce la faro'!!
Posso solo ringraziarti tantissimo, meglio sarebbe offrirti da bere ma chissa'...
Ultima cosa, come carico il tutto all'avvio?

CITAZIONE(skizzo3000 @ Sun 21 Oct 2012, 06:14 PM) *
io mi fermo qui xk il problema relativo ai moduli e fritz mi pare RISOLTO wink.gif
Per il resto ti invito a scrivere nei forum specialistici.

Sk3

skizzo3000
se hai il frimware moddato con freetz... vai nella gui del freetz http://ip:81
e cerca nei menu rc.custom e ci metti i comandi che vuoi eseguire al boot.

Sk3
gasgas
Che impedito...
trovato ma mi dice
Warning: Settings are not available at current security level!

Dovrei aggiungere questo, esatto?
modprobe ftdi_sio vendor=0x0403 product=0x6011
cd /var/media/ftp/uStor11
./oscam -c /var/media/ftp/uStor11 -b

CITAZIONE(skizzo3000 @ Sun 21 Oct 2012, 08:11 PM) *
se hai il frimware moddato con freetz... vai nella gui del freetz http://ip:81
e cerca nei menu rc.custom e ci metti i comandi che vuoi eseguire al boot.

Sk3

skizzo3000
CITAZIONE
cd /var/media/ftp/uStor11
./oscam -c /var/media/ftp/uStor11 -b


Meglio mettere
CITAZIONE
/var/media/ftp/uStor11/oscam -c /var/media/ftp/uStor11 -b


nel menuconfig c la voce dell'impostazione livello di sicurezza... io ho messo 0 wink.gif
quindi tutti i FW che faccio hanno la facolt di mod via web le impostazioni del freetz.

Se non ti va di rifare il FW puoi cercare l'impostazione tra i files nel fritz e settarla a 0.

Sk3
gasgas
Ok, rifatto firmware.
Per il resto mi hanno detto in giro di provare a settare lo smargo con certi valori, ma poi mi hanno detto che per il triple dovrebbe uscire un utility per fare questi settaggi.
Tu ne sai qualcosa? puo' essere vero o tutta una bufala?

CITAZIONE(skizzo3000 @ Sun 21 Oct 2012, 11:51 PM) *
Meglio mettere


nel menuconfig c la voce dell'impostazione livello di sicurezza... io ho messo 0 wink.gif
quindi tutti i FW che faccio hanno la facolt di mod via web le impostazioni del freetz.

Se non ti va di rifare il FW puoi cercare l'impostazione tra i files nel fritz e settarla a 0.

Sk3

skizzo3000
io non conosco smargo.
gasgas
Rieccomi Skizzo con una nuova sfida...
Dopo lo stop forzato dell'accoppiata oscam+smargotriple, ho letto in giro che si potrebbe usare anche cccam.
Ho trovato alcune versione compilate per freetz, ma non vanno. Tu sai qualcosa?
Poi su alcuni siti tedeschi ho visto che ci sono propriuo delle immagini freetz con nei menu le voci cccam oscam 3dcam....
Ma dato che il tedesco e' molto peggio del mio ingelese mi sono dovuto arrendere!!!
skizzo3000
no nn ho mainavuto necessita' di usare la ciccia su fritz xke' ho semprenfatto tutto con oscam.

al massimo puoi ricompilare oscam da zero... l'ultima versione e' migliorata moltissimo.

sk3
gasgas
CITAZIONE(skizzo3000 @ Mon 17 Dec 2012, 10:19 PM) *
no nn ho mainavuto necessita' di usare la ciccia su fritz xke' ho semprenfatto tutto con oscam.

al massimo puoi ricompilare oscam da zero... l'ultima versione e' migliorata moltissimo.

sk3

compilare per me e' una parola che non compare neanche sullo zanichelli :-D
Tu non e' che ne avresti una gia' pronta? Perche' se ti chiedessi di spiegarmi come compilarla
mi sa che arriva l'anno nuovo...
La cosa strana e' che oscam.to, si trovano, credo, gia' pronte per mipsel 7390, ma se le metto su e le lancio a mano
danno errore.
Comunque il mio problema e' il lettore, che probabilmente ha bisogno di alcuni settaggi che con oscam non si riesce.
Dato che la ciccia fa tutto da sola per questo volevo provarla.
Ma dato che anche questa che ho trovato per freetz non gira, mi sorge un dubbio. Non sara' la mia immagine che ho sul 7390?
gasgas
ciao skizzo, sono di nuovo a infastidirti....
ho perso tutti i vecchi file del firmware e aggiornando il 7390 mi ha perso le modifiche che avevo per oscam.
Allora volevo rifare da capo magari col nuovo 06.01. Con ubintu 13 non mi funzionva, dopo aver scaricato freetztrunk quando lancio make menuconfig mi risponde una cosa simile

ERROR: The program autoconf was not found in path.
ERROR: The program automake was not found in path.
ERROR: The program g++ was not found in path.
ERROR: The program gawk was not found in path.
ERROR: The program git was not found in path.
ERROR: The program libtool was not found in path.
WARNING: The program bison was not found in path.
WARNING: The program flex was not found in path.
ERROR: The header file ncurses.h was not found in /usr/(local/)include.
ERROR: The header file zlib.h was not found in /usr/(local/)include.
ERROR: The header file sys/acl.h was not found in /usr/(local/)include.
ERROR: The header file sys/capability.h was not found in /usr/(local/)include.
Makefile:125: *** Some build prerequisites are missing! Please install the missing packages before trying again. Stop.

allora ho riprovato con la 12, e mi si ripresent il problema di umask 0022 che non riesco a risolvere. anzi, cancellando e la dir del freez e rifacendo da capo mi presenta lo stesso errore sopra della 13.
Cosa devo fare? Sbaglio a installare la freetz?
bye
skizzo3000
non hai seguito la guida di nstallazione di freetz !

CODICE
sudo apt-get -y update
sudo apt-get -y upgrade
sudo apt-get -y dist-upgrade

sudo apt-get -y install graphicsmagick subversion gcc g++ binutils autoconf automake automake1.9 automake1.8 libtool make bzip2 libncurses5-dev zlib1g-dev flex bison patch texinfo tofrodos gettext pkg-config jikes ecj-bootstrap fastjar realpath perl libstring-crc32-perl ruby ruby1.8 gawk python libusb-dev unzip xz-utils

# Angepasst z.B. auf ubuntu 9.04 (kein automake 1.8, "ecj" statt "ecj-bootstrap" und ergnzt um "intltool"):
sudo apt-get -y install graphicsmagick subversion gcc g++ binutils autoconf automake automake1.9 libtool make bzip2 libncurses5-dev zlib1g-dev flex bison patch texinfo tofrodos gettext pkg-config jikes ecj fastjar realpath perl libstring-crc32-perl ruby ruby1.8 gawk python libusb-dev unzip intltool

# on a 64-bit system one also has to install the following 32-bit development packages
sudo apt-get -y install libc6-dev-i386 lib32ncurses5-dev gcc-multilib

#Ubuntu 13.04 64 bit
sudo apt-get -y install graphicsmagick subversion gcc g++ binutils autoconf automake automake1.9 libtool make bzip2 libncurses5-dev zlib1g-dev flex bison patch texinfo tofrodos gettext pkg-config ecj fastjar realpath perl libstring-crc32-perl ruby ruby1.8 gawk python libusb-dev unzip intltool libacl1-dev libcap-dev libc6-dev-i386 lib32ncurses5-dev gcc-multilib


per umask basta digitare
CODICE
umask 0022


prima di lanciare il make

Sk3
gasgas
Grazie skizzo....
ho fatto, ma non e' bastato, poi ho trovato un altro comando per scaricare altr librerie e poi e' partito.
Ora pero' ho un altro problema. Ho visto che con il nuovo sw 06.01 non mi da le opzioni per il kernel, quindi ho usato o il 05.05 o il 05.02, ma con entrambi alla fine mi da errore.
Alle volte per toobig, altre un altro errore e non mi crea il file image. Aggiungo solo quello che mi hai detto tu nei primi post,
nano
tcpdump
usb_serial
ftdixx
cpxxx
plxxx

anzi mi avevi detto anche usb-ftdi.ko ma non lo trovo.
tu non e' che hai un image gia' modificato?
skizzo3000
devi fare un clean prima di ricompilare.

Sk3
gasgas
CITAZIONE(gasgas @ Sun 21 Oct 2012, 03:29 PM) *
Ok, per adesso babbo e' fermo al casello...
allora, la card irdeto sembra andare, le altre 2 tvasat nagra e un' "altra" ritornano un errore e non si inizializano a dovere.
ti ellego il log


immagino che il comando sia clean???
ma se lo lancio mi dice comando non trovato....
skizzo3000
make clean

"fare pulito" smile.gif

Sk3
gasgas
CITAZIONE(skizzo3000 @ Tue 4 Feb 2014, 07:26 PM) *
make clean

"fare pulito" smile.gif

Sk3


ok, fatto, ecco che errore mi esce alla fine del make

----------------------------------------------------------------------
ERROR: modpatch: Error in patch-file make/linux/patches/2.6.28.10/025-mips_fix_loading_of_modules_with_unresolved_weak_sy.patch
make: *** [source/kernel/ref-iks-7390_05.21/.unpacked] Errore 2
skizzo3000
che versione stai usando di freetz ?

Sk3
gasgas
CITAZIONE(skizzo3000 @ Tue 4 Feb 2014, 11:34 PM) *
che versione stai usando di freetz ?

Sk3


trunk...
skizzo3000
si ma che checkout stai usando ?

che versione svn ?

Sk3
gasgas
CITAZIONE(skizzo3000 @ Wed 5 Feb 2014, 07:35 PM) *
si ma che checkout stai usando ?

che versione svn ?

Sk3


dall'alto della mi aignoranza credo l'ultimo, avendolo appena installato.
facendo svn up mi dice 11640
gasgas
adesso l'ho rifatto modificando solo il fw 05.51 anziche 05.2x e ha funzionato!!!
Ora provo a metterlo su....
ma con la versione 6 non si possono ancora fare tali modifiche?
gasgas
Ok ok....grazie al mitico anche sta volta l'ho spuntata....
sparesti dirmi dove trovare una versione recente della oscam per il 7390?
skizzo3000
scarichi i sorgenti e la compili con freetz...

oscam-9503 allegati

Sk3
Questa è la versione 'lo-fi' del forum. Per visualizzare la versione completa con molte più informazioni, formattazione ed immagini, per favore clicca qui.
Invision Power Board © 2001-2020 Invision Power Services, Inc.