Ultimo Urlo - Inviato da: skizzo3000 - Domenica, 12 Gennaio 2014 15:59
Impegnato in LiberaIlVoIPLiberaIlVoIP
 
Reply to this topicStart new topic
> Porta 23 Telnet Bloccata
bluesocks
messagio Tue 7 Sep 2010, 02:15 PM
Messaggio #1


Newbie
*

Gruppo: Members
Messaggi: 9
Iscritto il: 11-October 07
Utente Nr.: 1,041



Caro Skizzo, seguo con interesse i tuoi lavori e apprezzo molto la tua competenza e conoscenza dei prodotti AVM; possiedo un fritzbox 7240 tedesco da parecchio tempo dove a suo tempo caricai un firmware modificato da annex. Recentemente mi capita una cosa molto curiosa perchè non riesco ad accedere da remoto alla porta 23 telnet nonostante sia abilitata e attribuita al IP corretto.
Inizialnmente pensavo che si trattasse della linea ADSL (tiscali) ma provando anche con la chiavetta UMTS sortisco lo stesso effetto. Ho provato a resettare il FB ai parametri di fabbrica ma niente da fare. Usando anche tools online per la verifica delle porte mi dice che la porta è chiusa. Aggiungo che provando a raggiungere un server telned che ho all'esterno il tutto funziona. A te è mai capitato nulla di simile? è come se qualcosa si fosse inceppato a livello di parametri.
Ti ringrazio anticipatamente se mi vorrai/potrai rispondere
Go to the top of the page
 
+Quote Post
skizzo3000
messagio Tue 7 Sep 2010, 07:47 PM
Messaggio #2


Administrator
***

Gruppo: Admin
Messaggi: 2,373
Iscritto il: 22-March 05
Utente Nr.: 1



non puoi direttamente fare il forward della porta 23 verso il fritz.
Non è previsto dalle regole del fritz. dovresti fare la regola a mano via telnet modificando il file
/var/flash/ar7.cfg
Ricorda xò che è sconsigliato usare telnet per l'accesso remoto.
La gui web la puoi raggiungere in https, la console in ssh solo se hai un firmware moddato con freetz e con il pakketto apposito x ssh.

Ciao Sk3


--------------------
I manuali sono sempre la prima cosa da leggere !



NGI Eolo 6/2Mb - Super WoW



Linkem WiMAX (valor medio in copertura ottimale)
Go to the top of the page
 
+Quote Post
bluesocks
messagio Tue 7 Sep 2010, 10:53 PM
Messaggio #3


Newbie
*

Gruppo: Members
Messaggi: 9
Iscritto il: 11-October 07
Utente Nr.: 1,041



Grazie per la tua pronta risposta, probabilmente non sono stato molto chiaro nel porre la questione, il mio problema non è quello di rendere visibile il telnetd del fritzbox da remoto ma di rendere visibile un terminale telnet di una macchina linux presente nella rete (192.168.1.25). Ho impostato l'abilitazione nell'apposita pagina "abilitazione porte" indicando lìindirizzo IP sopra e la porta 23.
Nelle abilitazioni ho impostato anche l'FTP allo stesso indirizzo e alla pora 21 il risultato che ottengo da remoto è che l'FTP è raggiungibile, il telnet no nonostante la regola impostata.
Go to the top of the page
 
+Quote Post
skizzo3000
messagio Tue 7 Sep 2010, 11:36 PM
Messaggio #4


Administrator
***

Gruppo: Admin
Messaggi: 2,373
Iscritto il: 22-March 05
Utente Nr.: 1



domanda di rito: in locale funziona telnet ?
Hai provato a nattare la porta (che sarebbe anche piu sicuro) tipo aprire la 9023 estreno verso la 23 interno ?
Controlla via telnet nel fritz se la regola è scritta correttamente controllando il file /var/fritz/ar7.cfg


Sk3


--------------------
I manuali sono sempre la prima cosa da leggere !



NGI Eolo 6/2Mb - Super WoW



Linkem WiMAX (valor medio in copertura ottimale)
Go to the top of the page
 
+Quote Post
bluesocks
messagio Wed 8 Sep 2010, 01:31 PM
Messaggio #5


Newbie
*

Gruppo: Members
Messaggi: 9
Iscritto il: 11-October 07
Utente Nr.: 1,041



In locale funziona sia indicando l'IP della rete interna che facendo un telnet su XXX.dyndns.org sempre dall'interno. Ho nettato porta 23 su 23 ma posso provare anche la 9023 sebbene per tagliare la testa al toro in extremis ho impostato anche un Exposed host che dovrebbe coprire tutto il range di porte ammissibili; anche in questo caso niente da fare.
Go to the top of the page
 
+Quote Post
skizzo3000
messagio Wed 8 Sep 2010, 05:14 PM
Messaggio #6


Administrator
***

Gruppo: Admin
Messaggi: 2,373
Iscritto il: 22-March 05
Utente Nr.: 1



allora hai una configurazione del telnet server non corretta....che sistema è ?


--------------------
I manuali sono sempre la prima cosa da leggere !



NGI Eolo 6/2Mb - Super WoW



Linkem WiMAX (valor medio in copertura ottimale)
Go to the top of the page
 
+Quote Post
bluesocks
messagio Wed 8 Sep 2010, 05:23 PM
Messaggio #7


Newbie
*

Gruppo: Members
Messaggi: 9
Iscritto il: 11-October 07
Utente Nr.: 1,041



Il sistema è linux quindi un normalissimo daemon telnetd che comunque in locale funziona benissimo, a riprova l'ho provato lo stesso con un'altro
fritzbox e funziona normalmente sia in locale che in remoto
Go to the top of the page
 
+Quote Post
skizzo3000
messagio Wed 8 Sep 2010, 05:43 PM
Messaggio #8


Administrator
***

Gruppo: Admin
Messaggi: 2,373
Iscritto il: 22-March 05
Utente Nr.: 1



quindi hai individuato che il problema è sicuramente il fritzbox che stai usando ?

Controlla le regole d firewall via telnet
cat /var/flash/ar7.cfg

e cerca l'ip locale del sistema linux.

Sk3


--------------------
I manuali sono sempre la prima cosa da leggere !



NGI Eolo 6/2Mb - Super WoW



Linkem WiMAX (valor medio in copertura ottimale)
Go to the top of the page
 
+Quote Post
bluesocks
messagio Wed 8 Sep 2010, 09:24 PM
Messaggio #9


Newbie
*

Gruppo: Members
Messaggi: 9
Iscritto il: 11-October 07
Utente Nr.: 1,041



In effetti nel file ar7.cfg pare mancare la voce "forwardrules" nonostante abbia impostato 5 regole dall'interfaccia web molto strano
Go to the top of the page
 
+Quote Post
bluesocks
messagio Wed 8 Sep 2010, 09:48 PM
Messaggio #10


Newbie
*

Gruppo: Members
Messaggi: 9
Iscritto il: 11-October 07
Utente Nr.: 1,041



mi correggo, ho trovato ecco la regola:
forwardrules = "tcp 0.0.0.0:443 0.0.0.0:443 0",
"tcp 0.0.0.0:21 192.168.1.25:21 0 # FTP-Server",
"tcp 0.0.0.0:80 192.168.1.25:80 0 # HTTP-Server",
"tcp 0.0.0.0:23 192.168.1.25:23 0 # Telnet";

di queste la 21 e la 80 finzionano, la 23 no la 443 la imposta lui di default perchè sulla pagina web non compare
Go to the top of the page
 
+Quote Post
skizzo3000
messagio Wed 8 Sep 2010, 10:49 PM
Messaggio #11


Administrator
***

Gruppo: Admin
Messaggi: 2,373
Iscritto il: 22-March 05
Utente Nr.: 1



la regola è corretta... cavolo !! Non mi è mai successo xkè io non uso mai telnet ma sempre e solo ssh... puoi fare una prova del genere... ti salvi la conf del fritz e lo formatti con un recovery image, configuri solo il minimo indispensabile e fai subito la regola. Se così funziona allora è la tua attuale conf che si è pasticciata x qualche oscuro motivo. Se continua a non funzionare scrivimi versione firmware attuale e modello e versione di quello con cui hai fatto la seconda prova.

Sk3


--------------------
I manuali sono sempre la prima cosa da leggere !



NGI Eolo 6/2Mb - Super WoW



Linkem WiMAX (valor medio in copertura ottimale)
Go to the top of the page
 
+Quote Post
bluesocks
messagio Thu 9 Sep 2010, 05:10 PM
Messaggio #12


Newbie
*

Gruppo: Members
Messaggi: 9
Iscritto il: 11-October 07
Utente Nr.: 1,041



Premetto che la prova del recovery con una versione tedesca ex novo e con una minima configurazione/regole l'avevo già fatta con scarsi risultati, stanotte ho rifatto una seri di prove per cercare di scartare con metodo tutto quello che è irrilevante da quello che è o sembra essere importante; ti espongo la cronologia e il mio ragionamento.
C'è un prologo relativo alle prove fatte con altri router simili dislocati in due posti geograficamente diversi e disponibili in remoto; considera che la configurazione è la stessa cioè router con macchina linux con daemon ftp, daemon telnetd e http sulla porta 80. I due ruter sono uno 7270 uno 7140; entrambi hanno abilitato le porte corrispondenti e funzionano regolarmente anche dalla mia rete senza problemi quindi le porte sono accessibili in modo bidirezionale.
Stanotte ho voluto fare delle prove sul 7240 incriminato per capire se fosse lui il motivo di questo problema o altro; per fare questo ho provato a cambiare la regola telnet settando la porta 9023 che puntava all'interno alla 23 del IP desiderato. Ovviamente mi sono collegato in desktop rempoto su un pc che sta all'esterno (anche perchè dall'interno funziona benissimo), e ho telnettato sulla 9023, risultato nessun collegamento. A questo punto mi è sorto il dubbio che il problema potesse non essere il router ma nensì linea ADSL (Tiscali). Ho provato a fare una ulteriore prova disabilitando il portforwarding alla 21 (FTP) e telnettando sulla 21 forwardata all'interno sulla 23 all' IP desiderato; con mia sorpresa il collegamento è avvenuto anche se parzialmente nel senso che si è instaurata la connessione ma si blocca nel momento in cui chiede user e passw. Mi rendo conto che non è un successo pieno ma questo mi fa sorgere il dubbio che Tiscali in qualche modo mi abbia chiuso la porta 23 (e altre????). ho provato a fare un port scan dall'esterno ed effettivamente la porta 23 me la da come chiusa diversamente da quello che succede sugli altri routers dove risulta aperta.
Ho fatto una ulteriore prova collegando il router con una chiavetta UMTS Vofafone ma anche con quella mi risulta irraggiungibile; ti è mai capitato di sentire che un provider possa chiudere una porta così importante come la telnet?
Go to the top of the page
 
+Quote Post
skizzo3000
messagio Fri 10 Sep 2010, 12:04 AM
Messaggio #13


Administrator
***

Gruppo: Admin
Messaggi: 2,373
Iscritto il: 22-March 05
Utente Nr.: 1



eh se mi dicevi che avevi tiscali ti rispondevo gia che tiscali blocca di suo appunto la 23 e ne filtra altre con la scusa di proteggere l'utente. Leggi bene il contratto che hai sottoscritto, ci sarà una voce che rigarda la protezione dell'utente.... tiscali non è x nulla neutrale !! Così come vodafone !!

Sk3


--------------------
I manuali sono sempre la prima cosa da leggere !



NGI Eolo 6/2Mb - Super WoW



Linkem WiMAX (valor medio in copertura ottimale)
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 utenti stanno leggendo questa discussione (1 visitatori e 0 utenti anonimi)
0 utenti:

 

Versione Lo-Fi Oggi è il: 23 September 2018 - 03:16 PM